PDA

View Full Version : Question about diamond rock 2.0



Dusty12
July 16th, 2014, 09:05 PM
I have just put a new string on my 2010 diamond rock 2.0 and everything is in spec. The ATA,BH, DW. But here is my dilemma http://img.tapatalk.com/d/14/07/17/ama5ara5.jpg. Something isn't right and I can't figure it out. Does anyone have any pics of one from that angle I could look at. It looks like the cable slide is pulling it over way to much. Any info would be greatly appreciated

Diamond2
July 27th, 2014, 11:53 AM
I have a 2010 Diamond Rock 2.0. Great bow. It is pretty quiet as it is, but I was wondering if anyone has any thoughts about adding some BowJax accessories, and if so, what would you recommend? Thanks

Diamond2
July 27th, 2014, 12:19 PM
Here is a picture of my 2010 Diamond Rock 2.0, hopefully pretty close to the same angle as yours. For clarification, is the black looking string the one that connects to the cable slide and the oragne looking string is the actual string that goes over the pulley and down to the cam? The string that comes over the top of the pulley and down to the cable slide should appear to slant slightly left from the view in the attached picture and the string as it passes over the pulley and extends down to the cams appears to slant just slightly right. Take a look at the attched picture and see how it compares to yours. My strings are black so there isn't the contrast like your picture. The slant of your cable string appears a little extreme. Is it possible that you have your cable slide on the wrong side of your slide bar?

dwagoner
July 29th, 2014, 03:27 AM
you have to set idler lean and make sure its correct. cables pulled over and its gonna be going off side but did you twist the Y in buss any when installing new cable???