Hoyt In-Line roller guard problem

&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp

Results 1 to 18 of 18
  1. #1
    Join Date
    Feb 2011
    Location
    Darrington,WA
    Posts
    67

    Hoyt In-Line roller guard problem

    I bought a new hoyt Rampage XT little less than a month ago and my in-line roller guard housing is chewing up my string. Hoyt said to take it to a dealer and would fix it, but they have never see this problem. I was just wondering if anyone else is having this problem. DSCF0243(resized).jpg

  2. Remove Advertisements
    ArcheryTalk.com
    Advertisements
     

  3. #2
    Join Date
    Apr 2006
    Location
    Midwest - IL
    Posts
    10,019
    Hmm, something ain't right.
    Mathews Halon 32 | Mathews Halon |
    Spot Hogg | Sitka Gear | Lone Wolf | Zeiss|

  4. Remove Advertisements
    ArcheryTalk.com
    Advertisements
     

  5. #3
    I would call Hoyt again and tell them the proshop didn't have a clue. Good luck.
    Hoyt Carbon Spyder 30 ZT
    100gr G5 T3
    Easton FMJ 400

    "The greater the sacrifice, the greater the reward." LIFT, RUN, SHOOT

  6. #4
    Join Date
    Mar 2005
    Location
    Whitmore Lake, Michigan
    Posts
    5,748
    Yikes! Looks like it somehow got, (or is getting) pinched between the roller guard and the roller guard mount. But it sure looks like it got pinched to me. Either way, you're going to have to have that cable re-served.
    2014 Hoyt Carbon Spyder Turbo x2 / QAD HDX / Center Circle Bow Strings / Hogg-It Wrapped / 10" Bee Stinger / Carter RX1 / Tru Ball Blade Pro / Tru Ball HBC / NAP Spitfire 100 gr. / Easton ACC 3-49 / Blazers / ASAT Camo / Jim Beam / Copenhagen / Ford Trucks
    **Don't Tread On Me**

  7. #5
    Join Date
    Feb 2010
    Location
    Southern Oregon
    Posts
    2,945
    dang, that dont look good! Hopefully you get it fixed and be back to shooting soon

  8. #6
    Do you wax your string too much?

  9. #7
    Join Date
    Feb 2008
    Location
    Tupelo, MS
    Posts
    1,472
    Could possibly be a bur on the roller guard that didn't get machined smooth? Most likely they will replace the roller guard. Heck, if it were mine I would have them replace the cables too since it is new. Good luck. Glad you noticed it before it cut through.

  10. #8
    Join Date
    Feb 2011
    Location
    Darrington,WA
    Posts
    67
    I've only waxed the string 1 time in the month that i have had it.

  11. #9
    Join Date
    Mar 2005
    Location
    Whitmore Lake, Michigan
    Posts
    5,748
    Quote Originally Posted by kilswitch View Post
    I've only waxed the string 1 time in the month that i have had it.
    And you wouldn't/shouldn't be waxing the serving anyway.......
    2014 Hoyt Carbon Spyder Turbo x2 / QAD HDX / Center Circle Bow Strings / Hogg-It Wrapped / 10" Bee Stinger / Carter RX1 / Tru Ball Blade Pro / Tru Ball HBC / NAP Spitfire 100 gr. / Easton ACC 3-49 / Blazers / ASAT Camo / Jim Beam / Copenhagen / Ford Trucks
    **Don't Tread On Me**

  12. #10
    Join Date
    Jan 2008
    Location
    Doinkerville in the Nation of Hoyt
    Posts
    21,465
    I would guess a bur or the roller was put in backwards. Yes, there is only one way it should be put in.

  13. #11
    Join Date
    Feb 2011
    Location
    Darrington,WA
    Posts
    67
    well I am glad that no one else has had this prob so maybe an easy fix. theres no burs on the roller its that the string just isn't sitting down in the roller and is rubbing the housing. So it's off to the pro shop i go.

  14. #12
    Join Date
    Jan 2010
    Location
    Duvall, Wa.
    Posts
    243
    I had a roller bearing go bad on 2010 Maxxis. You can pull the bolt out of the roller, remove the roller and verify the bearing is not sloppy in the roller. Look for rubbing on the side of the mount. That is how I noticed my issue.

  15. #13
    Join Date
    Apr 2010
    Location
    north carolina
    Posts
    1,197
    Brother I have about 2000 shots or more on my XT, and my cables are slick. Something is not right there for sure.

    Hope you get it fixed soon.

    Hoyt should stand by that one.

    Good luck.

  16. #14
    Join Date
    Nov 2002
    Location
    Cowansville, Pa
    Posts
    31,170
    probably just a bad roller guard.
    $79.95 Bowstring & Cable Sets Hidden Content
    Save 10% at Hidden Content with promo code AT10
    Ebay Store Hidden Content
    Visit our Website Hidden Content Hidden Content Hidden Content Hidden Content Hidden Content
    Like us on Hidden Content Hidden Content Hidden Content Hidden Content

  17. #15
    Join Date
    Feb 2011
    Location
    Darrington,WA
    Posts
    67
    Its at the shop now getting a new roller guard and sting under warranty. Should be good to go when i get it back.

  18. #16
    Join Date
    Oct 2010
    Location
    indiana
    Posts
    69
    i need to know how 2 remove the rollers on the in-line roller guard tring 2 replace strings and cables on my 2010 maxxis

  19. #17
    Join Date
    Mar 2009
    Location
    Mountains of Western N.C.
    Posts
    5,116
    hate that happened, but Hoyt will fix it!

  20. #18
    Join Date
    Aug 2007
    Location
    fayetteville oh
    Posts
    5,421
    Each roller has an allen screw.jst remove it and the rollers will come off.
    Quote Originally Posted by andygut View Post
    i need to know how 2 remove the rollers on the in-line roller guard tring 2 replace strings and cables on my 2010 maxxis

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •