Results 1 to 6 of 6

Thread: bushnell trophy cam wont power up???

  1. #1
    Join Date
    Dec 2003
    Location
    south central,PA.
    Posts
    1,696

    bushnell trophy cam wont power up???

    tested all batteries and they are good,hit power button and nothing at all?? any thoughts?? thanks!!!

    Athens Archery Field Staff
    Athens Accomplice 34


  2. #2
    Join Date
    Aug 2010
    Location
    Wentzville, MO
    Posts
    211
    I don't remember if this affects it or not - but is there a card inserted?
    Any day spent in the woods is better than a day at work.

  3. #3
    Join Date
    Aug 2010
    Location
    Charleston SC
    Posts
    780
    Try a different SD card, or reformat the one you have. Check the new batteries with a voltmeter to make sure they are good batteries.

  4. #4
    Join Date
    Jun 2006
    Location
    central Wisconsin
    Posts
    1,763
    How long did you wait for it to power up? Mine, 2009 model sometimes takes longer to power up. I have turned it setup mode and it doesn't light up the screen, but then go to power mode and the red light on the out side lights up, which means it is working. It has done this several times and each time I let it go and it keeps working.

  5. #5
    Join Date
    Dec 2003
    Location
    south central,PA.
    Posts
    1,696
    you nailed it ACCMAN! tried new card and camera powered up and was able to read screen and set up menu,thanks to all who answered!!
    Athens Archery Field Staff
    Athens Accomplice 34

  6. #6
    Join Date
    Mar 2006
    Location
    Central Michigan
    Posts
    2,253
    Great call on the card Owen and glad to hear you are up and running again Jason, sometimes it's the little things....

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •