Archery Talk Forum banner

1 - 20 of 25 Posts

·
styger
Joined
·
1,132 Posts
Discussion Starter · #1 ·
I have been waiting for some time for my Alien. I wanted it with raw cams as in all of the pictures out and about. Unfortunately I had to switch my order to black as I was told unanodized cams would not be available. Now when the bow comes the modules are unanodized and the cams are black? Doesn't look so good to me. I would prefer all one or the other. The box and bow are marked to 30 inches but the bow is set to 29 and the modules are not tapped clear through to adjust. I finally get it set to 30 and get it set up to shoot. Great draw, smooth, and the bow locks on target effortlessly. This bow is a dream to aim. The camo is fine and the limb graphics are good. The bow is plain pretty. Now for the bad part. On the shot it is fairly loud and every other shot the string hits the string stop on the edge and jumps the string out of the cam track. Luckily the draw stop is quite large and on the bottom cam or the bow would have come apart. I get to looking at the pictures of other Aliens on here and they all seem to have bent rods on their stoppers. Mine is straight and doesn't even come close to hitting the center of the string. Being off centered is causing the string to glance off and derail from the track. I hope I can get a bent cable rod and the bow quiets down a bit. Talk to the dealer today and see what gives.
 

·
Registered
Joined
·
805 Posts
I have not had the string jump off the track. I have noticed you need a real
neutral hand positon it is possible you have enough hand torque to cause a problem but I personally have not had a problem.
 

·
In the begining God......
Joined
·
3,710 Posts
I have been waiting for some time for my Alien. I wanted it with raw cams as in all of the pictures out and about. Unfortunately I had to switch my order to black as I was told unanodized cams would not be available. Now when the bow comes the modules are unanodized and the cams are black? Doesn't look so good to me. I would prefer all one or the other. The box and bow are marked to 30 inches but the bow is set to 29 and the modules are not tapped clear through to adjust. I finally get it set to 30 and get it set up to shoot. Great draw, smooth, and the bow locks on target effortlessly. This bow is a dream to aim. The camo is fine and the limb graphics are good. The bow is plain pretty. Now for the bad part. On the shot it is fairly loud and every other shot the string hits the string stop on the edge and jumps the string out of the cam track. Luckily the draw stop is quite large and on the bottom cam or the bow would have come apart. I get to looking at the pictures of other Aliens on here and they all seem to have bent rods on their stoppers. Mine is straight and doesn't even come close to hitting the center of the string. Being off centered is causing the string to glance off and derail from the track. I hope I can get a bent cable rod and the bow quiets down a bit. Talk to the dealer today and see what gives.

I might also say if you are shooting it and have an annodized cam, and a raw module there could be some diecrepency in the thickness of each, not matching and that little extra thickness may cause a problelm. Not for sure just a thought.
 

·
Registered
Joined
·
5,465 Posts
All of the Aliens that I have seen pictures of have the bend in the sts rod. I would talk to the dealer or Martin and see if you can get the correct mods and sts for it.
 

·
Custom callmaker
Joined
·
3,473 Posts
I would want another plain and simple.

The sts rod being different and not working. The cams and mods not matching. The holes not tapped out. What the heck is this for quality. A mixed bag of whats lying around.

I say BS and demand a new one. There is not excuse for anything like this leaving the factory. It works or it don't. Its good to sell or its not.
 

·
Registered
Joined
·
1,044 Posts
Hope

I would hope QC would pick those kind of things up.....I hope mine lands lookin purdy and complete:angry:

That said, I am sure that you will be hearing from "someone" very soon to make things right. Good Luck to ya!!!
 

·
Registered
Joined
·
5,465 Posts

·
Registered
Joined
·
5,663 Posts
I just saw another on that looked exactly the same in another alien thread. I thought all of the modules were black and the STS rods were off set?

http://www.archerytalk.com/vb/showthread.php?t=901785
I can't tell if the string stop on that bow has an angled rod or not. I don't like the looks of the modules not being black either...I'd be tempted to have them powdercoated to match the alien logo though:evil:

I'm sure your issues will be resolved shortly. In the mean time, don't shoot your bow..its not good if it is coming off track.

Well, it is not angled...That is odd in one way, but not really because you would expect that they could line the string suppresor up straight from the factory. This would create a stronger rod (not that one is really needed).
 

·
Registered
Joined
·
3,322 Posts
Hey Nontypical... I just posted pics of my alien and then saw your thread... I don't have any of the probs you are having with your bow. Mine is set at 30"/70lbs, shoots awesome. It does need a small stab to absorb the vibration, but with any 3.5 lb bow, shooting 330+ you are going to need something to absorb it. It flat out shoots:thumbs_up:tongue:
 

·
Registered
Joined
·
3,322 Posts
I would want another plain and simple.

The sts rod being different and not working. The cams and mods not matching. The holes not tapped out. What the heck is this for quality. A mixed bag of whats lying around.

I say BS and demand a new one. There is not excuse for anything like this leaving the factory. It works or it don't. Its good to sell or its not.
The Alien is new enough that I don't think there is a "standard" for them yet... Martin is making improvements even now as they are shipping proven quality bows. Progress never stops there - but you can't say that bout some of the companies. They are on here and are aware of any post claiming issues with their product. and should there be an issue, they are top notch in taking care of it.
 

·
styger
Joined
·
1,132 Posts
Discussion Starter · #12 ·
Hey Nontypical... I just posted pics of my alien and then saw your thread... I don't have any of the probs you are having with your bow. Mine is set at 30"/70lbs, shoots awesome. It does need a small stab to absorb the vibration, but with any 3.5 lb bow, shooting 330+ you are going to need something to absorb it. It flat out shoots:thumbs_up:tongue:
Mightyelk, what kind of speed are you getting at 30 inch. I shot a 351 grain arrow through the chrono today at 329 which I thought was not right either. Might need a complete overhall. The bow shoots about 2 inch tail left with the rest in any position as well.
 

·
Registered
Joined
·
1,044 Posts
Ohhh

WOW!!! I hope mine comes through with the modules black! It would be silly..lol Having a blacked out bow with raw silver mods. Expecially after getting new accessories to make it all black......
 

·
Registered
Joined
·
2,856 Posts
It may be a case of the sts being too close to the string.

You should have about 1/8" between the string and the stopper. I am planning to replace my stock sts with a paradigm CTA. When the cta comes in, I'll let you know. If your still having issues with your straight one you can have my offset sts.
 

·
Registered
Joined
·
1,044 Posts
Question....

JWT, how does the stock supressor attach to the riser, does the CTA not need a bushing? How will you attach the CTA?

I look forward to the results.
 

·
styger
Joined
·
1,132 Posts
Discussion Starter · #16 ·
You should have about 1/8" between the string and the stopper. I am planning to replace my stock sts with a paradigm CTA. When the cta comes in, I'll let you know. If your still having issues with your straight one you can have my offset sts.
Are you going to epoxy a bushing in to attach the CTA? I think I'm going to find some brass bushings and do the same thing.
 

·
Time Flies
Joined
·
13,281 Posts
Mightyelk, what kind of speed are you getting at 30 inch. I shot a 351 grain arrow through the chrono today at 329 which I thought was not right either. Might need a complete overhall. The bow shoots about 2 inch tail left with the rest in any position as well.
329 isn't right? How much were you expecting from it? Unless you're shooting with just a bare string, you generally won't hit any IBO mark from a manufacturer. The left tear is most likely a result from an incorrectly spined arrow; you can always get a tear perfect with moving your rest position provided your spine is perfect.
 

·
Registered
Joined
·
8,222 Posts
LOL, I would think 329 is pretty impressive myself . Have your dealer call Rytera, I am sure they will take care of your issues
 

·
styger
Joined
·
1,132 Posts
Discussion Starter · #20 ·
329 isn't right? How much were you expecting from it? Unless you're shooting with just a bare string, you generally won't hit any IBO mark from a manufacturer. The left tear is most likely a result from an incorrectly spined arrow; you can always get a tear perfect with moving your rest position provided your spine is perfect.
Just a string loop. No peep or silencers. I've seen some pretty impressive numbers from the 60 pounders with 28 and 29 inch draws. Was hoping for 6-7 fps more. However, I was not complaining about the speed even though it's 10-12 fps under IBO spec. I was just curious if there is indeed a "setup" issue with the bow.
 
1 - 20 of 25 Posts
Top