Archery Talk Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
1,234 Posts
Discussion Starter #1
Hey guys...i am really having trouble keeping my blazers on my arrows. I used goat tuff glue with an arizona fletcher. I wiped 91% alcohol on the arrow wrap and then fletched. Everything goes good until i shoot them once or twice. Usually 1 vane on each arrow comes off. I re fletch them and have the same problem again. Never had this problem with my 4inch duravanes.What am i doing wrong?
 

·
Registered
Joined
·
2,994 Posts
I have not had any problems with blazers. I wipe the arrow with denatured alcohol, then use Bohning instant gel. I shot all summer with them & haven't had any come off. I do not touch the edge of the vanes at all.

Ray Ray
 

·
Registered
Joined
·
242 Posts
I have never had any problems at all. I would try putting a dab of glue at the front of the vane and at the back. Also try using AAE fastset gel , it works wonders.
 

·
Registered
Joined
·
5,101 Posts
I have never had any problem with losing the blazers, i never clean the shaft, just put them on with maxi-cure super glue, I have used them on Carbon Express and Gold tips, never had a problem yet....
 

·
Matt R
Joined
·
2,113 Posts
I use the green " Scotch-Brite " pads ( the same ones you use to wash dishes ) to lightly " scuff " the arrows. They work great....I have never had a Blazer come loose yet.
 

·
Registered
Joined
·
11,484 Posts
I put wraps on and then glue the Blazers on with Fletch Tite platinum and you will rip the wraps trying to pull one off:)

I don't clean the Blazers. I do clean the shaft before I wrap it with denatured alcohol.
 

·
Registered
Joined
·
1,880 Posts
I just use Loctite super glue jell works fine
 
1 - 8 of 8 Posts
Top