Archery Talk Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
265 Posts
Discussion Starter #1
I keep getting contact no matter what I do with the cord. What might cause this. I am also getting a left tear. I believe that this is from the vane contact. Any Ideas?
 

·
Registered
Joined
·
325 Posts
Sorry, no ideas. I have one and i dont really like it. I only bought it because it was small, low profile and one of the guys at bass pro said it was the best fall away. If i pull my bow back quickly it falls right off. I hate it
 

·
Registered
Joined
·
4,473 Posts
Try loosing screw that hold launcher arm 1/8 of a turn then tighten the set screw to the arm. I had a problem and this took care of it.
 

·
Registered
Joined
·
265 Posts
Discussion Starter #5
I did loosen the screw a little. seemed to help. I read that there is a way to tighten the spring. Anyone heard of this?
 

·
No Hype, Just Hunt
Joined
·
12,419 Posts
I believe it should be on the side of the rest. Also was the rest installed perpendicular to the string? I have one on my bow and I shoot fobs and have zero contact issues. I have mine set to come completely up 1" before full draw and no matter how fast I draw I have not had it bounce the arrow up.
 

·
Registered
Joined
·
37 Posts
Love this rest btw, super quiet and smooth, but it's very important to mount it exactly perpendicular to the string. Use a string level to get the bow straight then level the rest as you mount it. Also tighten the small lock screw on the side or it will move on you. I also have mine set up to come up about an inch before full draw and have no contact problems at all. Good luck!
 

·
No Hype, Just Hunt
Joined
·
12,419 Posts
Love this rest btw, super quiet and smooth, but it's very important to mount it exactly perpendicular to the string. Use a string level to get the bow straight then level the rest as you mount it. Also tighten the small lock screw on the side or it will move on you. I also have mine set up to come up about an inch before full draw and have no contact problems at all. Good luck!
Yep

Here is a video link that better illustrates what we are trying to say.

G5 Expert 2 install video
 

·
Registered
Joined
·
265 Posts
Discussion Starter #10
I have two mounting screw using both berger holes so I assume that the rest is perp. to the string. I have the pull cord hooked to the cable slide right now. I am going to try adjusting the spring before connecting to the down cable. Mine starts coming up a little over half way through the draw and peaks 1-2 inches before full draw. I think the spring tension will fix the problem. I refletched some 2" fusion vanes and got them to shoot good. I just have to shoot a few to get the nock set correct to the vanes.
 

·
Registered
Joined
·
325 Posts
if you still have problems i know there is a great video on youtube and it was a big help. Also like someone said before, have it come completely up about an inch before you max draw or full draw.
 

·
Registered
Joined
·
265 Posts
Discussion Starter #12
Moved the cord to the down cable, have no problems now
 
1 - 12 of 12 Posts
Top