Archery Talk Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
272 Posts
Discussion Starter · #1 ·
I would like some input on a problem-----for the last 3 years I have been shooting Brand X (Martin,PSE,Bowtech,Mathews,Merlin) Just brand X-------This year I got a Hoyt 03 UT I have been shooting it for over 4 months-(I shoot every day)----and it seems no matter what I do I can NOT get it to shoot a group. I have worked on form---Paper tuned the bow, used different shafts,----I can't get it to shoot, There have been good ends but they are few and far between-------yesterday I picked up Brand X---and was shooting 25's right away (five spot)---good groups--Is any one else having this problem???????
NEED INPUT !!!!!!!!!!!!!!!!
A friend of mine is also having this same problem
 

·
7 Time pHp Camp Champion
Joined
·
7,287 Posts
Could you describe your set up a little more. I mean poundage, draw, arrow set up, tiller, etc. Also, have you done anything with the cams to make sure they're "timed?" We might be able to help some with a little more info.
 

·
Registered
Joined
·
272 Posts
Discussion Starter · #3 ·
FoggDogg

*I am shooting 50lbs at 28.5 in draw
**the UT has XT 3000 limbs --50lb
* Arrows are acc 3-39 cut at 29, fletec with 4" feathers
100 grain one piece points
**I have checked the tiller and they are equal
**We have added a few twists to the yoke to bring the cams into time
**I still have the origanal strings and cables on it
**I am using a solution 3 release off a d-loop (back tension)
**11.5" Super stick
NAP 4000
SureLoc Supreme
I was told by some that I needed to use a low wrist--when I did the bow always kicked out at the bottom
I am now using a mideum wrist and after the shot the bow just sits there-so I am not touqueing the bow

Hope this info helps
 

·
Registered
Joined
·
406 Posts
RoyH, are your string and cabels in your preformance marks? If so have someone watch your cams and see if the top flat grove is hitting the same time as the ftat spot on the bottom. If they are not then start by adding or taking a twist out of the top. Then do the opposite to the bottom. This may change your draw lenght, then you just move your moduels to get your draw back. If the cams are not hitting you may be over drawing with your back tension, thus giving you a high shot. I have the same bow UT w/3000 limbs.(67 lbs). The only other thing is I set my bow up without limb savers on it. I shot it for quit awhile, then put the limb savers back on and my groups at 50 yrds. when to crap. Ever since then they are off and staying off. I don't know if there is anything to it but it worked for me. Also make sure to write down everything you do, so you can change it back. Hope this helps, Jeff
 

·
X's R Us
Joined
·
3,458 Posts
Is that rest the drop away one? I would try using a regular prong or blade rest. I've got a cybertec and don't have grouping problems.
 

·
Registered
Joined
·
272 Posts
Discussion Starter · #6 ·
Ian--
Yes the rest is a drop away
I tried a nap 300-0-micro and that did not help at all
 

·
Registered
Joined
·
4,074 Posts
My 03 UT when paper tuned shoots like sh*t...... group tune it and you will see a night and day difference in how well it shoots.

I FINALLY found center around 11/16 inch from riser.

The arrows you chose are a little stiff, but that should be fine.

hope this helps.
 

·
Registered
Joined
·
2,461 Posts
Very similar problem , and as TAP said , found centershot just outside of 11/16ths , and this did help , but the bow is EXTREMELY critical to shoot , shot a 3D on Sunday & smoked it & on Monday was gonna shoot 1/2 a 900 and it was all I could do to keep all the arrows in the yellow.......let alone the 10 , pull out my old Aspen & bust nocks.......strange !!!!!!!! :confused:
 
1 - 8 of 8 Posts
Top