Archery Talk Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
2,394 Posts
The 29 I got has a pretty noticable vibration as well. More than my V3 and VXR. I also have a landslyde dovetail but I took the sight off the bow and it still does it. I have a few things in gonna try tomorrow to see if fixes the problem. I will report back.

Sent from my SM-G998U using Tapatalk
 

·
Registered
Joined
·
2,394 Posts
If you have a sidebar, check the caps/screws on the sidebar mount. Saw that one time on Chris’s Bee YouTube.

Other than that could be a mod screw or something small. Check and check every screw again especially on the axcel where there are screws on top of screws.. check them all again


Sent from my iPhone using Tapatalk
I've went over mine a few times and can't find anything wrong with it. It may just be one of those bows that has vibration. Some do and some don't in my experience.

Sent from my SM-G998U using Tapatalk
 

·
Registered
Joined
·
2,394 Posts
That’s interesting because when I take my sight off, noise is gone. I’m running their qad rest however and have been really happy with it. First shot bullet hole which I was super happy with
Yeah, I'm using the QAD integrate rest as well. I sure wish I could figure out what it is. Everyone I've talked to says they are absolutely dead in the hand and quiet as a church mouse. Really frustrating

Sent from my SM-G998U using Tapatalk
 

·
Registered
Joined
·
2,394 Posts
Buzzing can usually be tracked down and fixed, but some individual bows do vibrate more than other identical bows. I read somewhere that it can be down to how accurately the axle holes are drilled through the limbs. If a bow vibrates, take everything off except D loop and go from there to track down the culprit. I have two TRX40s set up the same in terms of poundage, DL etc. Both are dead bare bow. One vibrates a lot more than the other with an identical stabiliser and sight set up. Go figure.
Finally, someone that knows what I'm taking about.

Sent from my SM-G998U using Tapatalk
 

·
Registered
Joined
·
2,394 Posts
Mine is not the bow... I tried it on 3 different bows. It made noticeably more noise than the sight that was on each prior to trying it.
Did you try tightening the two little screws I suggested to the OP?

Sent from my SM-G998U using Tapatalk
 
1 - 8 of 8 Posts
Top