Archery Talk Forum banner

1 - 20 of 35 Posts

·
Registered
Joined
·
59 Posts
Discussion Starter #1
I had a 990i that I purchased last fall and it started taking red photos cause something in the lens was stuck. I have been waiting for a trail camera for over a month to be replaced and come home today to a box of new camera straps!!!! I was promised a camera like ten different times and just get the run around with this company. Everyone stay clear of them!
 

·
Registered
Joined
·
916 Posts
I purchased the 990i in December 2013, but placed it out for the first time in early September, I have it on video/audio. It's working fine, but a very annoying buzzing sound while I watch the videos. I contacted Moultrie numerous times, thinking maybe there is a upload fix for it, they have yet to reply back to me.
 

·
Registered
Joined
·
6,032 Posts
I sold all my Moultries a while back !!!!! Way too many excuses and too much BS. First I was using the wrong cards and then the wrong batteries and ..............

Enough !!!
 

·
Registered
Joined
·
60 Posts
Yeah I bought a new moultrie pro feeder when I opened no bottom hopper. Been over a month called and kept telling me it shipped out. I never got it called a week ago and was told it never shipped out and that its on backorder. Asked if they could send a complete new one and let me send back mine and they said they couldn't do that. So I'm done with moultrie.
 

·
Registered
Joined
·
5,210 Posts
This is not really what IWAN ted to hear about Moultries Customer Service.....I just brought my M80 out of the woods because for some odd reason its taking pics every minute (likes its stuck in plotcam mode) even though I have it in TrailCam mode.....and batteries were lasting 4000 shots down to roughly 1500....I planned on calling Moultrie tomorrow after work.
 

·
Registered
Joined
·
5,118 Posts
This is not really what IWAN ted to hear about Moultries Customer Service.....I just brought my M80 out of the woods because for some odd reason its taking pics every minute (likes its stuck in plotcam mode) even though I have it in TrailCam mode.....and batteries were lasting 4000 shots down to roughly 1500....I planned on calling Moultrie tomorrow after work.
At least if the they tell you what you don't want to hear you can say yea this is what I expected to hear there was a thread on AT about how bad your CS is. :wink:
 

·
Registered
Joined
·
59 Posts
Discussion Starter #7
I will be calling tomorrow morning first thing to complain some more. It's horrible. I have doubts I will even get a camera back at this point. I have no extra camaras so it really stinks I have to deal with this. Anyone have any recommendations to a trail camera company with good customer service?
 

·
Registered
Joined
·
183 Posts
I have a lot of moultrie cameras over the years and the cheap Chinese stuff just isn't cutting it anymore. I live in Bama and drive by the Moultrie place all the time. Think I will stop and have a talk with them. This customer service just isn't going to cut it.
 

·
Registered
Joined
·
1,355 Posts
I sold all my Moultries a while back !!!!! Way too many excuses and too much BS. First I was using the wrong cards and then the wrong batteries and ..............

Enough !!!
I have two cameras that are the exact same. I use the same batteries and SD cards in both. One stopped working completely and I called their CS. They said it was the SD card as well. I asked why one still worked just fine and the other didn't and she wouldn't give me an answer.
 

·
Registered
Joined
·
10,702 Posts
When the M80X cameras first came out I was having issues with two cameras. They would out of the blue when switching sd cards pop up and say card lock. No matter what card you put in them they would say card lock. Called them and went thru a bunch of rest thing san nothing worked so I sent both back. Both were less than a month old. I got one back that looked new while the other one looked to have been chewed on by mice or squirrels. While setting them up one did not have the motion freeze setting like my other 4 so another call to customer service was made and the lady was very nice but had no idea why any of my cameras had motion freeze. In fact she put me on hold for several minutes twice talking to other cs people and none knew any of their cameras had motion freeze. Took my number and was going to call me back after talking to some higher ups but never heard any more. So another call and I sent the camera without motion freeze back and a new one was returned. So far so good since then. It just seems there are NO good trail cameras unless you buy the 600.00 reconyx cameras.
 

·
Registered
Joined
·
5,608 Posts
I've been running Moultries for years a few different styles and haven't had any issues, some of my cameras are 4+ years old.
I'm happy with them. Good cameras for the price.
 

·
Registered
Joined
·
3,821 Posts
I ordered a feeder from them a while back.A month later they sent the wrong one.A cheaper model of course.I called and they had me call the warehouse.After and endless circle of calls, a person tried to tell me I got what I ordered no matter the price.No exchange, no refund and no return shipping.I sent it back at my cost.I hope they used my money wisely because I will never order from them again.
 

·
Registered
Joined
·
5,687 Posts
I purchased the 990i in December 2013, but placed it out for the first time in early September, I have it on video/audio. It's working fine, but a very annoying buzzing sound while I watch the videos. I contacted Moultrie numerous times, thinking maybe there is a upload fix for it, they have yet to reply back to me.
Have you checked to see if there is a firmware update that might fix the noise issue.

As for CS it is hit and miss I have never used it but had for another brand. I know of others that have sent in their Moultrie's and have got good service but right now is their busiest time and so their service might not be as good as it is earlier in the year. Not sure what you had going but I read on another game camera forum and some bought a 2014 that was not as good as their 2013 and when they sent in their 2014 they request a 2013 same model replacement and they did as they requested so again not sure what you has as to an issue with your Moultrie but heard other brands with even worse CS. Some have decent replacement service but when they have a high amount of returns they just send another that could have similar issues as I got or worse. Unless you buy a Reconyx most have similar complaints from customers. I have had 3 2013 Moultrie's and not had any issues with the M-880 and 2 M-990i and just picked up a M-1100i for a great price and their prices are a little better than some other brands and have not heard many that have had a bad experience with Moultrie CS but they are poor as to getting back to you seems they changed CS often it appears but some other companies have dropped their email because they get flooded with emails so again right now is the busy time so you have to take that into account but there is no excuse for any kind of poor service. What was the issue with their CS just slow shipping or what? You did not mention what it was.

LFM
 

·
Registered
Joined
·
863 Posts
I had a m80 quit working a couple weeks ago. It just quit triggereing when something passed by in front of it but it still works In plot mode and hybrid mode. I called moultrie and they told me the didnt even do repairs on there cameras and sent me a email with discounted prices on there cameras if I wanted to buy a new one. I can't really complain about the camera cause it was three years old and took at least 250/300 thousand pictures cause I run it year round. I figured it would lay down eventually but at least they offered discounted prices on a new cam if I wanted one.
 

·
Registered
Joined
·
863 Posts
All I run is m80 cams and have great luck with them. I would like to buy some of the new 880's but I've read some reviews from trail cam pro and they say that all the pictures are out of focus. Has anyone had any issues with these 2014 cams. The 880 and990
 

·
outback1
Joined
·
5,057 Posts
I have three of the POS cameras, one just quit working all together two won't take night pics, nothing like spending hard earned money on crap!
 

·
Registered
Joined
·
916 Posts
There isn't anything on their webpage informing people if there is a update to fix the noise, that is why I have tried numerous times with their CS people, but they haven't replied. I have a Moultrie I40, it was out for 5 yrs the only time I took it out of the woods would be around January 1st, and then back out in May, never any issues until this year the display was hard to read, that cam I got my monies worth
 

·
Registered
Joined
·
531 Posts
I must have been lucky. Owned 2 in the last 6 years and have had great luck. When one stopped working they replaced. That one last for 5 years until about 2 weeks ago.
 

·
Registered
Joined
·
2,949 Posts
I've been saying this about their customer service for years. If there cameras were free, I wouldn't waste my time running them. I hate that company.
 

·
Registered
Joined
·
2,947 Posts
i emailed them a problem i was having with getting pictures off a card a couple of weeks ago. never heard anything back. turns out it was user error but it would have been nice to at least see them attempt to help me. i've got to imagine their CS dept. is completely covered up right now though.
 
1 - 20 of 35 Posts
Top