Archery Talk Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
583 Posts
Discussion Starter #1
I recently put the sts on my bow and now it's super loud. That is the only thing I have changed and I don't understand how it could be louder. Any suggestions? I've tried moving the eds back and forth to see if that would help but it didn't. Has anyone else noticed this. I love the way it helps stabilize my move and it does great with reducing hand shock but the noise bothers me. Thanks for the help.
 

·
Straight Shooter
Joined
·
5,659 Posts
I really don't know either, how an sts could possible make your bow louder, unless something isn't set up properly, or a portion of the sts is not tightened down properly. The sts should take away a great deal of the vibration from your string after the shot, thus preventing most of the excess vibration on your bow. When you say your bow is louder, can you pinpoint the cause of the excess noise?

Is it possible something could have coincidentally come loose at the same time you put the sts on? The first thing I would do is tighten down EVERYTHING on my bow.
 

·
Registered
Joined
·
11,484 Posts
PAKraig said:
I really don't know either, how an sts could possible make your bow louder, unless something isn't set up properly, or a portion of the sts is not tightened down properly. The sts should take away a great deal of the vibration from your string after the shot, thus preventing most of the excess vibration on your bow. When you say your bow is louder, can you pinpoint the cause of the excess noise?

Is it possible something could have coincidentally come loose at the same time you put the sts on? The first thing I would do is tighten down EVERYTHING on my bow.
I think something is not right in China:)
 

·
Banned
Joined
·
10,353 Posts
When I tried an STS on the SQ2 I use to own it made my bow louder as well. Joe, the owner, actually told me that they were having an issue with the STS on shorter ATA bows, but the newer models wouldn't have the same issues. Instead of hearing string twang, I now had a LOUD popping sound when the string hit the supressor and no matter how I adjusted it, the popping would not go away. While it definitely took away hand shock and vibration as it is supposed to, I removed the STS and sold it to DB on here because I would rather have a little bit if string twang as opposed to a very loud popping sound.
 

·
The Impartial Archer
Joined
·
18,304 Posts
PABowhunt4life said:
When I tried an STS on the SQ2 I use to own it made my bow louder as well. Joe, the owner, actually told me that they were having an issue with the STS on shorter ATA bows, but the newer models wouldn't have the same issues. Instead of hearing string twang, I now had a LOUD popping sound when the string hit the supressor and no matter how I adjusted it, the popping would not go away. While it definitely took away hand shock and vibration as it is supposed to, I removed the STS and sold it to DB on here because I would rather have a little bit if string twang as opposed to a very loud popping sound.
That really doesn't make sense to me? The string force hitting the STS should be the same no matter what the ATA is. I have never heard it get louder on any thing I have put it on. I use to have a Q2 but I sold it before the STS became so popular. I had it on my SB\LD which is shorter than a Q2 and many have put it on the XT and it's only 31.5" ATA. I have had it on several Mathews, Bowtechs and now My Ross and it helps a lot if its adjusted right. Strange......:confused:
 

·
Registered
Joined
·
2,945 Posts
take it off then sheesh...

get a video cam
go outside take
have the vid cam facing you at about 20 yds
take a shot at a target (not the camera)
then play it back in review

do it with your STS do it without. which ever is most silent go for it.
 

·
Registered
Joined
·
307 Posts
Tighten everything on your bow down including the cam modules you may have. I once had a mod screw that was backing out from the shock of the shot. Tightenend it and the noise went away. I decided to check everything else out and found several screws that needed tightening.
 

·
Registered
Joined
·
1,107 Posts
Did you set it up like the instructions tell you too.The EDS stopper needs to be pushed into the string 1/16 of an inch.It will actually stop the string early.If there is a gap between the string and stopper it will sound like a firecracker going off.Also,make sure the bend in the arm is pointed up towards your nocking point and the string is hitting the stopper exactly in the middle.I have had both the old and new versions on an Ovation,Outback,Tribute and now my Ross and they work wonderful.Sounds like you just need to go back and re-adjust everything.Hope this helps.....
 
1 - 10 of 10 Posts
Top