Archery Talk Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
971 Posts
Discussion Starter #1
I am having problems with my SD cards for my trail cameras. I now have 3 cards that say memory card error, card locked and yes I have checked the little lock on the side. That it not the problem. The first cards it happened to (Kingston 2GB) was on my Scout guard and now I just checked my moultrie(PNY premium 4GB) and have one that says it now too. I use my lab top and camera to look at the pics and to erase my pics. Is there anything I can do to fix the cards and what do you think is causing the problem?
 

·
Registered
Joined
·
6,055 Posts
Is this a full size sd card or a micro card in a adapter. Some cards can have a virus right from the maker. With the Chinese the way they are who knows who that might be. It can say PNY but who knows.
 

·
Registered
Joined
·
1,027 Posts
I just had one do the same thing on a wildview. Ive had the card and camera for about 4years.had to get new card solved problem.
 

·
Registered
Joined
·
971 Posts
Discussion Starter #4
Is this a full size sd card or a micro card in a adapter. Some cards can have a virus right from the maker. With the Chinese the way they are who knows who that might be. It can say PNY but who knows.
It's a full size. Is there anyway to fix these cards? I hate to keep buying cards. Is it possible to get a virus from my lab top? These cards were not old maybe a month old.
 

·
Registered
Joined
·
503 Posts
I had the same problem the lock on the memory card looked to be ok but when i put it in the reader it says it was locked (even though visually it wasnt) This solved my problem and now it works everytime. http://www.youtube.com/watch?v=-g7dsoHJoTQ

Hope it helps you
 
1 - 6 of 6 Posts
Top