Archery Talk Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
1,086 Posts
Discussion Starter #1
I've got a 2017 PSE Evolve and recently noticed that there's a missing "O" ring from one of the roller glide spindles and by the looks of it the 2nd ring is not going to last much longer. Can't seem to find the specific part number or even mention anywhere about that specific of a piece to replace it. Anyone know how necessary those rubber "O" rings are? I've seen other brands of similar roller slides and it doesn't look like some of them even have those rings. Appreciate the help.
ring.jpg
 

·
Registered
Joined
·
1,086 Posts
Discussion Starter #3
Yeah, I guess it should be THAT easy.
 

·
Registered
Joined
·
24,079 Posts
Take a good look at the design.....the roller has an "axle" that is held between two arms (see post #4). You cannot simply slide the O-ring on to the roller without removing the pin/axle. I had an Evoke and well understand what the OP is speaking of. Hope you get it figured out.
 

·
Registered
Joined
·
1,116 Posts
Take a good look at the design.....the roller has an "axle" that is held between two arms (see post #4). You cannot simply slide the O-ring on to the roller without removing the pin/axle. I had an Evoke and well understand what the OP is speaking of. Hope you get it figured out.
Did you try removing the rod with a punch?
 

·
Registered
Joined
·
24,079 Posts
Did you try removing the rod with a punch?
No, my Evoke was pretty new and didn't need to have that process done. I actually replaced the entire rod and roller glide with a carbon rod from McMaster-Carr and a Saunder's Hyper Glide....and liked the draw cycle better.
 

·
Registered
Joined
·
19,018 Posts
I would try removing the remaining o-ring & try shooting with out them & see if there is any difference, I did that with an old Saunders 4X4 roller slide & worked good.
 
1 - 10 of 10 Posts
Top