Archery Talk Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1,109 Posts
Discussion Starter #1
I have a reflex excursion that makes a creak noise in the top limb/cam when you draw the bow. Only the first time you draw, keep shooting it and no problem. Let it sit for 15 minutes and it will creak again- just once. Any one have this problem?
 

·
Registered
Joined
·
1,492 Posts
Yes I've had that problem

I used to own an Excursion myself and had that very problem. (Fine bow for the money by the way.)

The cause of my creak was a slightly loose bolt on one of the cams. Get out your allen wrenches and tighten them all and I'll bet your creak goes away. Not all all uncommon I guess to loosen up a bit especially on a new bow.

just curious, is your Excursion new?
 

·
Registered
Joined
·
1,492 Posts
Let us know

Please let us know if that was the culprit. I don't want to give bad advice to the next guy if it doesn't solve your problem.
 

·
Registered
Joined
·
4,927 Posts
I've had the same problem on two Hoyts,and I do not think it is uncommon as I have seen it mentioned here at AT a few times.
With the first bow(Ultramag)I was able to correct the problem myself by spraying a synthetic lube on the top cam axle.The second bow(Ultratech)was not as easy.The lube did not work,but the bow was new so I took it back to the pro shop.They thought it was the limb pockets,so they took down the bow and lubed both pockets.That did not work.Finally they pulled the top axle, lubed it,and I have had no "creaking"noises since.
 

·
Registered
Joined
·
2,718 Posts
I have a 6 month old Reflex Timber Wolf. The only time that I noticed the creaking sound was when I maxed out the limbs (70# bow). When I back the limb bolts off 1/2 turn, I no longer heard the creaking.
 
1 - 6 of 6 Posts
Top