Archery Talk Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
603 Posts
Discussion Starter #1
Hi guys. Have any of you ever encountered an issue with a Ripcord Code Red (or similar rest?) where the rest will stick during drawing the bow and finally move to the upward position once you have drawn it far enough? I'm not sure if that is a clear explanation of the issue. Basically, I go to draw, start drawing back and rest doesn't move, draw further and rest very quickly snaps to its upright position. This happens maybe once every 5-6 shots, with the other times the rest moving to position gradually through the draw as normal. Any insight would be appreciated. Thanks.
 

·
World & National Champion
Joined
·
33,999 Posts
Usually when we see this the launcher is getting caught on the back of the riser and then flings up once there is enough tension.
www.60xcustomstrings.com
 

·
Registered
Joined
·
603 Posts
Discussion Starter #3
Usually when we see this the launcher is getting caught on the back of the riser and then flings up once there is enough tension.
www.60xcustomstrings.com
Thanks for the reply. On the bow this one is on, the rest sits above the riser and actually doesn't make any contact with it. I'm leaning towards something binding inside the rest, but won't take it apart until I have received a replacement rest I put on order.
 

·
Shooter of flesh
Joined
·
7,660 Posts
If the rest as a BUNCH of shots through it, the cable may be worn out and ready to break.

Pull on the cable, and look where it goes into the rest body. If u see fraying, replace the cable.

You might also have gotten some gunk or dirty water inside the body causing it to stick.
 

·
Registered
Joined
·
603 Posts
Discussion Starter #5
If the rest as a BUNCH of shots through it, the cable may be worn out and ready to break.

Pull on the cable, and look where it goes into the rest body. If u see fraying, replace the cable.

You might also have gotten some gunk or dirty water inside the body causing it to stick.
Thanks, I'll be sure to check the string. I will end up taking it apart to see if anything obvious is the issue.
 

·
Registered
Joined
·
603 Posts
Discussion Starter #7
Ripcord will fix or replace it for free if you send it to them.
Thanks for the heads up. Should I avoid opening it then, to ensure I don't void the warranty on it?
 

·
Registered
Joined
·
2,231 Posts
Check to see if your cable slide is sticking on the cable rod. My wife's bow was chattering/sticking causing the rest issue.
 

·
Registered
Joined
·
603 Posts
Discussion Starter #9
Check to see if your cable slide is sticking on the cable rod. My wife's bow was chattering/sticking causing the rest issue.
Thanks for that idea. I will check that as well once I get home from work today.
 

·
Registered
Joined
·
946 Posts
Those things are pretty darn solid, just a few parts. Open it up and look at the burnt end of the loop material. If its too big it could be catching. Great company, if it is a defect they WILL replace. I ruined a launcher when I had my Omen because of that issue, it wasnt falling and my vanes just plowed right through it. They sent me 3 launchers at no charge!
 

·
Registered
Joined
·
14,341 Posts
Try some oil on the launcher and work it down into the bushing. If that doesn't work on top of the rest of the suggestions, call ripcord and they will fix you up with a new one.
 

·
Premium Member
Joined
·
10,922 Posts
You do know that this rest works better if it's cocked into up position first, right? The cord is not supposed to be used to raise the rest. Just to unlock it once you hit full draw.
 
1 - 12 of 12 Posts
Top