Archery Talk Forum banner

Ripcord Issue

492 Views 2 Replies 3 Participants Last post by  Kelsnore
Hey guys on my 82nd airborne I have the ripcord fall-away rest. I haven't had any problems with it until this past week. The rest isn't falling away on me, but it happens very sporadically, for instance tonight I was at a 3d shoot, and it happened once in my 30 shots. I am really stumped as to what is causing this, does anyone have any ideas? It doesn't fall away at all, so it isn't a clearance issues. Any help would be greatly appreciated.
1 - 3 of 3 Posts

· Banned
Joined
·
1,567 Posts
Hey guys on my 82nd airborne I have the ripcord fall-away rest. I haven't had any problems with it until this past week. The rest isn't falling away on me, but it happens very sporadically, for instance tonight I was at a 3d shoot, and it happened once in my 30 shots. I am really stumped as to what is causing this, does anyone have any ideas? It doesn't fall away at all, so it isn't a clearance issues. Any help would be greatly appreciated.
Ive heard they have had these issues in the past. call ripcord and they should send you another one.
 

· Registered
Joined
·
5,552 Posts
The actuator cord runs through a plunger that can be sharp on the edges eventually cutting through the cord! Also, pull out the cord from the body of the rest, as the cord also wears where it runs into the hole of the rest body!!

The plunger could also be hanging up on the catch internally, usually caused by a burr on the plunger!!! A smooth cut file can fix that problem! Other than that, a new cord installed...simple stuff!!!
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top