Archery Talk Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2,044 Posts
Discussion Starter · #1 ·
Was wondering if anyone here is having problems with them on a switchback?I seem to be getting a deep cut in the top one. Is this even a problem.Bottom is not as bad.Looking for some feed back
 

·
Registered
Joined
·
33 Posts
I just got my Switchback, so it doesn't have much wear on anything yet. It is also my first Mathews with the String Suppressors. However, it is my understanding that these will wear out, but I don't know how long that is supposed to take. If I was you I would talk to your Mathews dealer, there may be a tuning problem or it may be normal. Either way, he is the one that can answer the question best for you.
 

·
NC ASA Director
Joined
·
36,016 Posts
I have been shooting mine all year with no problems. Sometimes you can notice a small tear in the top one because it is longer than the bottom one.

Are your limbs backed off a lot, and is your axle to axle in spec?
 

·
Registered
Joined
·
611 Posts
suppressor wear

check the setup on bow. if ATA or brace height has changed the suppressor will cut. also make sure cam is in time. the suppressors are marked for cam and idler, they are different. cable stretch will cause this.
 

·
Registered
Joined
·
2,044 Posts
Discussion Starter · #5 ·
Sage that seems to the problem with mine.But im at 65lbs 29inch draw.Its not bad its just worse than the bottom one.Got over 1000 shots on them.Thanks for the info
 

·
Registered
Joined
·
481 Posts
From what I have seen on the switch if the string &/or cable has streyched you will get wear in the suppressors/check the string & cable, axle to axle & brace heigth. Make any corrections needed & it should stop the wear.
 

·
Registered
Joined
·
1,148 Posts
More than likely your bow is out of spec (ATA, BH, Cam Timing, etc.).

If the suppressor is cut badly, I'd replace it.
 
1 - 7 of 7 Posts
Top