Archery Talk Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
71 Posts
Discussion Starter #1
I have a Limbsaver DZ32. QAD rest. I cannot get my vanes from contacting the rest. I have 2" blazer vanes. I've taken it to a bow shop, etc and after much shooting, which is accurate, I still get 2 nice racing stripes on the vanes. Any ideas? Being a new archer and this being my first bow, I'm much in the learning process.
 

·
I hate tundra!
Joined
·
1,544 Posts
I have a Limbsaver DZ32. QAD rest. I cannot get my vanes from contacting the rest. I have 2" blazer vanes. I've taken it to a bow shop, etc and after much shooting, which is accurate, I still get 2 nice racing stripes on the vanes. Any ideas? Being a new archer and this being my first bow, I'm much in the learning process.
I have one on my Tribute and had to take it apart and tighten the spring a little to make it fall faster.
 

·
Registered
Joined
·
178 Posts
I had the same problem with a trophy taker. The problem for me was to low of a nocking point. My buddy found this video and it solved my problem.
http://www.youtube.com/watch?v=eZK7O_s1Rq8[/URL]
 

·
Registered
Joined
·
14 Posts
I just changed out my sight for a new one. While sighting it in I noticed that there was some marking on my QAD Ultra Rest Pro HD. Also I noticed on my practice arrows that the vanes were getting a bit marked also.

That link to the video is nice... but... it doesn't really say how to fix the problem... nor do I have a high-speed video system to check mine.

Anybody have ideas on how to fix this tuning issue?

Is it simply I need to raise my knocking point a bit?

Thanks to replies.

-Brian
 

·
Registered
Joined
·
827 Posts
Does your string hook to your buss cable at-least 5" lower then the rest when drawn? I have heard a lot of guys say the same thing as rabbit you may have to tighten the spring.
 
1 - 6 of 6 Posts
Top