Archery Talk Forum banner

1 - 20 of 20 Posts

·
Registered User
Joined
·
3,330 Posts
Discussion Starter #1
Im getting alot of vibration from my Armortech for some reason.. Its like a tuning fork.. I took it apart and everything still the same.. Checked all the bolts.. Anyone else getting this problem...I love the sight just need to find out what is making the noise..
 

·
Registered
Joined
·
4,110 Posts
Armortech Sight

I had the same problem with mine on one of my bows. It ended up being the add on light that I installed. Tightened it up, and no further issues. Did you go as far as tearing down the inner guts of the sight? Maybe something inside. They are very easy to take apart. If you haven't done this, I would tear it completely down, and tighten everything back up as you put it back together. I love my Armortech.
 

·
Retired GI "still serv'n"
Joined
·
13,960 Posts
I had the same problem and it was the phillips head screw that holds the Gang adjustment knob shaft in place.
It is at the bottom of the sight housing.
One twist with a screwdriver while holding the knurled knob on top with my hands and it tightened right up and the rattle/ vibration noise went away.
 

·
Registered
Joined
·
6,208 Posts
Well, I did have the same thing happen, I checked all the bolts, and it was none of them. Ended up being the mounting screws. Brandon Reyes was on the phone with me walking me through the disassembly of the sight!:)
 

·
Registered
Joined
·
16 Posts
I had a slight noise from mine as well.

I talked to Randy at Axcel last Thursday and he's taking care of my problem as I type this. I had to send mine back to Axcel. Last year's model had a bushing issue in the windage gang adjuster. They are modifying my sight and I should have it back maybe Thursday. Awesome customer service!! Thanks Randy!!
 

·
Registered User
Joined
·
3,330 Posts
Discussion Starter #6
Ya I had it all apart and everything seemed to be tight.. I tried tighening the screws also and still had the issue.. Jeff do u mean the screws where it mounts to the bow.. Thanks for the replies guys..
 

·
Registered
Joined
·
2,682 Posts
Mine also makes a little noise when i tap on the riser and everything is locked down...Maybe I should call
 

·
Registered
Joined
·
6,208 Posts
Ya I had it all apart and everything seemed to be tight.. I tried tighening the screws also and still had the issue.. Jeff do u mean the screws where it mounts to the bow.. Thanks for the replies guys..
Yep..
 

·
Registered User
Joined
·
3,330 Posts
Discussion Starter #9
I just spoke with Randy at Axcel and he said just send it in they already know what the problem is... Awesome Customer Service..Fire give Randy a call.. I quess on certain ones there is a issue with a spacer in the adjustment.. Easy fix... Thanks for all the replies guys... Steve
 

·
Registered
Joined
·
8,301 Posts
Im getting alot of vibration from my Armortech for some reason.. Its like a tuning fork.. I took it apart and everything still the same.. Checked all the bolts.. Anyone else getting this problem...I love the sight just need to find out what is making the noise..
I just ordered one over the SH and it should be here any day. I hope I don't have that issue.
 

·
Registered
Joined
·
1,400 Posts
Im getting alot of vibration from my Armortech for some reason.. Its like a tuning fork.. I took it apart and everything still the same.. Checked all the bolts.. Anyone else getting this problem...I love the sight just need to find out what is making the noise..
Did you purchase it new, and if you did when?

I can take care of you with the answers to these questions.

Brandon
 

·
Classifieds Administrator
Joined
·
39,215 Posts
They have one of the best customer services out there. If you got a problem, its their problem and they will make it right.

I have an Armotech HD and shoot their releases for good reason, a great company stands behind them! :thumb:
 

·
Registered
Joined
·
2,781 Posts
Not sure if there is a 8/32 thread hole open on it but Doinker makes the Pee-wee Doinker sold in a set of 2 with a little tiny weight on it and it's sole reason for design was to help just what your having problems with.....it works as an exit point for vibration and they do really work, no voodoo. In fact call up the factory tomorrow and ask to speak to the Erick the VP and he will send you out a set to try. Just see if there is any place to stick a little 8/32 thread. (661) 948-7900 thats the line to the Doinker Factory
 

·
Registered
Joined
·
16 Posts
Ditto!

I don't think I can go back to another sight. They really do have great customer service.

They have one of the best customer services out there. If you got a problem, its their problem and they will make it right.

I have an Armotech HD and shoot their releases for good reason, a great company stands behind them! :thumb:
 

·
Registered
Joined
·
4,110 Posts
I'll have to test mine again, and see if I still have some noise I'm not aware of. I purchased mine quite some time ago. So I'm assuming I have one of the original ones that might have this bushing issue. I already know how to take the sight apart and put it back together. Is there a replacement part or upgrade that we can just have sent to us to fix this bushing issue ourself?
 

·
Registered
Joined
·
4,110 Posts
Armortech noise/vibration

I tested my sight again and did notice a little bit of vibration/noise still in it. Kind of like the tuning fork as mentioned above. Not nearly as bad as when I found that it was my add on light making noise, but still enough to bother me (I like zero noise and vibration :wink:). I'll have to look into this replacement part that was mentioned above. Hopefully it will be the cause for what I'm feeling and hearing.
 

·
Registered
Joined
·
16 Posts
Rattle Not Resolved Upon return

I've been using a Trophy Ridge Flatliner while my sight was away for return, no rattle. I installed the Armortech back on and got the rattle came back after a few shots. I can eliminate the rattle by loosening and re-tightening the windage/elevation adjusters but the rattle comes back. So I checked the invoice on the returned sight and they could not find the rattle so no repair was performed. So looks like I'm back to square one. I'll play around with it and try to find out the culprit of the noise and update you guys. If anyone has any suggestions, please let me know.

Also, no light is installed on it at the moment.

Thanks!!
 

·
Registered
Joined
·
16 Posts
whitetail25

Hi Steve,
Where you able to resolve your noise issue? I still can't pinpoint mine. Going to try the good old process of elimination. Remove the head and shoot. I'll keep on removing parts till I pinpoint the noise. Please let me know what took care of yours. Mine is definitely in the sight cause my bow was quiet with the flatliner.
 

·
Registered
Joined
·
313 Posts
both of my armortech sound like tuning forks. for my target sight it doesnt really matter but my hunting sight is so bad im ready to throw it outta a tree.
 
1 - 20 of 20 Posts
Top